Sorry your browser is not supported!

You are using an outdated browser that does not support modern web technologies, in order to use this site please update to a new browser.

Browsers supported include Chrome, FireFox, Safari, Opera, Internet Explorer 10+ or Microsoft Edge.

Newcomers AppGameKit Corner / Windows/Linux Builds 100% - HTML5 Build Has OGG Loading Error Frequently?

Author
Message
JeZxLee
2
Years of Service
User Offline
Joined: 15th Mar 2017
Location: Long Island, New York, United States, Earth
Posted: 18th Oct 2019 01:16
Hi,

Building and running on Windows & Linux is 100%.

When I build HTML5 and upload to my site I frequently get an OGG can't load error?
I checked the OGG's and they look OK, but this error still frequently occurs on HTML5 build.
(happens on all Internet browsers on both Windows 10 and Kubuntu Linux)

My OGG's(music and sound effects) are mono/22050Hz/90kbps.
Again, I never seen an OGG loading error when running Linux or Windows builds.
Only when running HTML5 version on any Internet browser on Linux or Windows.

Sometimes happens...
And what is weird is if I recompile and upload the OGG error sometimes goes away?
Makes no sense to me at all.

Any ideas?
I need to solve this issue...

I am using AppGameKit Classic(I own Studio, but HTML5 export is missing so I don't use it yet)

Jesse
JeZxLee
Fallen Angel Software
Video Game Design Studio
http://www.FallenAngelSoftware.com
JeZxLee
2
Years of Service
User Offline
Joined: 15th Mar 2017
Location: Long Island, New York, United States, Earth
Posted: 18th Oct 2019 20:58
Not sure on the above issue....

It never shows an OGG loading error when running Windows/Linux native builds.
Only sometimes when running HTML5 build.

I'll keep investigating...

Jesse
JeZxLee
Fallen Angel Software
Video Game Design Studio
http://www.FallenAngelSoftware.com
PSY
Valued Member
3
Years of Service
User Offline
Joined: 3rd Jul 2016
Location: Laniakea Supercluster
Posted: 19th Oct 2019 20:35
Try Stereo 44KHz


PSY LABS Games
Coders don't die, they just gosub without return
JeZxLee
2
Years of Service
User Offline
Joined: 15th Mar 2017
Location: Long Island, New York, United States, Earth
Posted: 19th Oct 2019 23:10
"Stereo 44KHz"

Above is not good, music would be very large.
Mono 22KHz is what I currently use - is that bad?

Thanks!

Jesse
JeZxLee
Fallen Angel Software
Video Game Design Studio
http://www.FallenAngelSoftware.com
PSY
Valued Member
3
Years of Service
User Offline
Joined: 3rd Jul 2016
Location: Laniakea Supercluster
Posted: 20th Oct 2019 18:20
Personally, I wouldn't use Mono.
I'd rather use Stereo and export it with lower quality settings.

Try Audacity, it's free.


PSY LABS Games
Coders don't die, they just gosub without return
DannyD
2
Years of Service
User Offline
Joined: 29th Aug 2017
Location:
Posted: 21st Oct 2019 14:10
I had a similar issue with some image errors with HTML5. I finally figure out it is case sensitive, which don't bother in Windows or android, but in HTML5
Eg. My image name "Mypic.JPG" and I reference in code as "mypic.jpg".
Took me a while to figure that out...
Might be something similar with your ogg filename


Login to post a reply

Server time is: 2019-11-17 20:00:25
Your offset time is: 2019-11-17 20:00:25