Sorry your browser is not supported!

You are using an outdated browser that does not support modern web technologies, in order to use this site please update to a new browser.

Browsers supported include Chrome, FireFox, Safari, Opera, Internet Explorer 10+ or Microsoft Edge.

AppGameKit Studio Chat / T2 VS Questions

Author
Message
BitManip
6
Years of Service
User Offline
Joined: 20th Dec 2013
Location: Essex
Posted: 15th Dec 2019 15:30
Hi All,

Its been a loooong while wanted to get back into T2 but have run into some early issues.

1) I can only seem to download VS2019 not 2017? Can I use 2019?
2) When compiling HelloAppGameKit, finally got the directories sorted but it tells me agk has no member agk::InitGL...

Any ideas where I am going wrong?


Thanks in advance
I control all the juicy in here!
Bored of the Rings
15
Years of Service
User Offline
Joined: 25th Feb 2005
Location: Middle Earth
Posted: 15th Dec 2019 15:44
Yes you can still obtain vs 2017. They have links to previous version in archive section.
Professional Programmer, languages: SAS, C++, SQL, PL-SQL, DBPro, Purebasic, JavaScript, others
Bengismo
2
Years of Service
User Offline
Joined: 20th Nov 2017
Location: Yorkshire, England
Posted: 15th Dec 2019 16:07
I use Teir 2 with visual studio 2019 and it works fine.
BitManip
6
Years of Service
User Offline
Joined: 20th Dec 2013
Location: Essex
Posted: 15th Dec 2019 20:27 Edited at: 15th Dec 2019 20:42
Okay installed 2017. (Win 7)

Firstly tried building "HelloAppGameKit" and am told that in cSprite it cannot find Renderer.h. So added this to the extra directories. Then it says the same about InitGL not being a part of agk::??

So I tried closing that and loading template_windows_vs2017_64 (as I have a 64 bit system). Build and get a bundle of warnings but one error "LNK1127 library is corrupt...libcucrtd.lib?

any helpers?

What SDK should I have?
I control all the juicy in here!
BitManip
6
Years of Service
User Offline
Joined: 20th Dec 2013
Location: Essex
Posted: 16th Dec 2019 16:26
[SOLVED] Aparently the 2017 installation did not complete correctly (with no shown errors).

Now it works!!!! Hoooooooooooooooooooooooooooraaaaaaaaaaaaaaaaaaayy
I control all the juicy in here!
george++
12
Years of Service
User Offline
Joined: 13th May 2007
Location: Hellas
Posted: 31st Dec 2019 11:24 Edited at: 31st Dec 2019 11:25
Quote: "I use Teir 2 with visual studio 2019 and it works fine."

Does this mean that you make use of the Vulkan API?

Login to post a reply

Server time is: 2020-02-26 07:18:01
Your offset time is: 2020-02-26 07:18:01