Sorry your browser is not supported!

You are using an outdated browser that does not support modern web technologies, in order to use this site please update to a new browser.

Browsers supported include Chrome, FireFox, Safari, Opera, Internet Explorer 10+ or Microsoft Edge.

AppGameKit Studio Chat / App Game Kit Studio Tier 2 settting up?

Author
Message
shadey
10
Years of Service
User Offline
Joined: 25th Jan 2010
Location:
Posted: 4th Jul 2020 21:17 Edited at: 4th Jul 2020 23:29
Hi, I want to try using c++ via tier 2 but have no idea how to go about it on linux mint, as the only tutorial online:
[video=youtube]hMwkvCQ0910&t[/video]

is for visual studio on windows!
Hail to the king, baby!
Bengismo
2
Years of Service
User Offline
Joined: 20th Nov 2017
Location: Yorkshire, England
Posted: 4th Jul 2020 23:56
In the "app game kit tutorials 1-5 download" in your downloads page on TGC...you can download a PDF which is specifically about Getting Started With AppGameKit on Linux Teir 2.

It covers the setup and the needed libraries...its not mint specific, but if your familiar with linux then its not a bad start. I had trouble with it at first but got there in the end.
shadey
10
Years of Service
User Offline
Joined: 25th Jan 2010
Location:
Posted: 5th Jul 2020 12:18 Edited at: 5th Jul 2020 12:19
Thanks man, must've missed that!
Hail to the king, baby!
shadey
10
Years of Service
User Offline
Joined: 25th Jan 2010
Location:
Posted: 5th Jul 2020 14:50 Edited at: 5th Jul 2020 16:59
hmmmm...having problems completeting this, when I get to having to put:

cmake -G "Unix Makefiles"
I end up with the following error list:



even though I followed every step!
Dont know if that means i dont have a compiler or what, will it help if i type the old ...
sudo apt-get install build-essential
??

EDIT** tried that and it did get further,but still errored with:





Edit** ok solved that with:
sudo apt-get install xorg-dev libglu1-mesa-dev


This is being a pain as I thought ,might aswell keep posting progress for others to benefit..hopefully this is the last problem!

Right, got things up to changing the paths to the libs in the makefile within Kdevelop, obviously I have done it wrong: here is a screenshot



I had created a folder in my home directory called App_Game_Kit_Libs...
Hail to the king, baby!
shadey
10
Years of Service
User Offline
Joined: 25th Jan 2010
Location:
Posted: 5th Jul 2020 20:13 Edited at: 5th Jul 2020 20:14
still got no luck configuring this makefile:
here is what I have:





and here are the errors if i try to build..


Hail to the king, baby!
shadey
10
Years of Service
User Offline
Joined: 25th Jan 2010
Location:
Posted: 6th Jul 2020 09:28 Edited at: 6th Jul 2020 09:30
hmmm! Anyone??

been messing about with this makefile within Kdevelop following the guide for tier 2 and still cannot get it right:




Hail to the king, baby!
MadBit
Valued Member
11
Years of Service
User Offline
Joined: 25th Jun 2009
Location: Germany
Posted: 6th Jul 2020 12:42
I am not sure but there must be no space between the -I,-L option and the path.
"-I /home/david/AppGameKitLibs/common/​include"​ -> "-I/home/david/AppGameKitLibs/common/​include​"
Share your knowledge. It\'s a way to achieve immortality. (Tenzin Gyatso)
shadey
10
Years of Service
User Offline
Joined: 25th Jan 2010
Location:
Posted: 6th Jul 2020 13:31 Edited at: 6th Jul 2020 13:38


this is what I have tried next.. seperating the INC's, but I still get the errors.. tried these with and without spaces


Hail to the king, baby!
Dark Raven
6
Years of Service
User Offline
Joined: 27th Jul 2014
Location: United States
Posted: 6th Jul 2020 18:28
Have your make file like the one before only make sure there is no space between the -I and paths just as Madbit had said. The last script the paths are typed correctly it just needs to be a single line as eash inc is overriding the previous one so it is only including the last include path and not all the paths.
shadey
10
Years of Service
User Offline
Joined: 25th Jan 2010
Location:
Posted: 6th Jul 2020 18:38
tried:


but still get:
Hail to the king, baby!
Dark Raven
6
Years of Service
User Offline
Joined: 27th Jul 2014
Location: United States
Posted: 6th Jul 2020 23:50
Yeah I'm not sure. I just tried and mine compiles. I did get that error at first but that was because I had my path incorrectly typed. So all I can say is make sure the paths are exactly how they are. Linux is case sensitive so you was make sure that all the characters in the include paths are the correct case. Other than that I don't know. Don't know if your actual project files are in the apps folder or not but I would try putting the folder there and then changing the paths to say -I/../../common/include; etc etc and seeing if that works. That is how the original template make files when downloaded directly from studio is listed.
shadey
10
Years of Service
User Offline
Joined: 25th Jan 2010
Location:
Posted: 7th Jul 2020 15:43 Edited at: 7th Jul 2020 15:49
I think I give up! A shame really,but anyhow what i did, coz i didnt really like linux mint, was just delete that and put ubuntu desktop on, then followed all the tutorial for tier2 again, everything goes just as smooth until configuring the makefile business : This is what I believe is correct:





I can physically see all the files/folders where they should be!
but still the same errors:

Hail to the king, baby!
Dark Raven
6
Years of Service
User Offline
Joined: 27th Jul 2014
Location: United States
Posted: 8th Jul 2020 04:25
H ave you tried seeing if the templates for Linux in the app folder of the tier 2 library can be built without modification?

Login to post a reply

Server time is: 2020-08-04 04:29:37
Your offset time is: 2020-08-04 04:29:37