Sorry your browser is not supported!

You are using an outdated browser that does not support modern web technologies, in order to use this site please update to a new browser.

Browsers supported include Chrome, FireFox, Safari, Opera, Internet Explorer 10+ or Microsoft Edge.

Android / 15+ Second Black Screen When App Is First Run(Cold Start)?

Author
Message
JeZxLee
3
Years of Service
User Offline
Joined: 15th Mar 2017
Location: Long Island, New York, United States, Earth
Posted: 3rd Aug 2020 16:44
Hi,

We have been away from AppGameKit developement for a long time.
We noticed a small typo in one of our AppGameKit games.
We updated our AppGameKit via Valve's Steam game client.

We fixed the typo in the game and built both Android and HTML5 versions.
We tested Android version on two different devices but there is a bad issue:
When we run our AppGameKit game on Android devices, there is a 15+ second delay where the screen is black?
(on cold start on Android a black screen is displayed for over 15 seconds before the actual game starts)

We made one change to the project to correct the typo.
The project was last built in 100% working order on Android.
Something bad has changed in AppGameKit when building for Android?

Please advise, we would like to update the game on Google Play but can't...

Jesse
JeZxLee
Fallen Angel Software
Video Game Design Studio
http://www.FallenAngelSoftware.com
JeZxLee
3
Years of Service
User Offline
Joined: 15th Mar 2017
Location: Long Island, New York, United States, Earth
Posted: 3rd Aug 2020 21:00
Game is open-source on GitHub below:
https://github.com/FallenAngelSoftware/AppGameKit2-SpaceSwap
JeZxLee
Fallen Angel Software
Video Game Design Studio
http://www.FallenAngelSoftware.com

Login to post a reply

Server time is: 2020-09-29 04:03:39
Your offset time is: 2020-09-29 04:03:39