Sorry your browser is not supported!

You are using an outdated browser that does not support modern web technologies, in order to use this site please update to a new browser.

Browsers supported include Chrome, FireFox, Safari, Opera, Internet Explorer 10+ or Microsoft Edge.

Bug Reports / [Dark Physics full version] Convex rigid bodies not attaching to host objects correctly

Author
Message
Redmotion
14
Years of Service
User Offline
Joined: 16th Jan 2003
Location: Mmm mmm.. Marmite
Posted: 8th Oct 2006 00:47
For some reason creating dynamic convex objects doesn't work everytime - sometimes they are created but not attached to the object. Leaving the object where it is and an invisible rigid body moving how it should. (see attachment.)

I took the identical scene file (in the picture) and replaced the convex bodies with box type rigid bodies and they attached and behaved correctly.

BLACKMESA:SOURCE - mod for HL2 - Texture Artist
BIRTHSTAR:FRONTLINE - Texture & Environment Artist

Attachments

Login to view attachments
Redmotion
14
Years of Service
User Offline
Joined: 16th Jan 2003
Location: Mmm mmm.. Marmite
Posted: 8th Oct 2006 17:19 Edited at: 9th Oct 2006 01:22
EDIT: sorry, one bug per post.

BLACKMESA:SOURCE - mod for HL2 - Texture Artist
BIRTHSTAR:FRONTLINE - Texture & Environment Artist
BatVink
Moderator
14
Years of Service
User Offline
Joined: 4th Apr 2003
Location: Gods own County, UK
Posted: 11th Oct 2006 10:48 Edited at: 11th Oct 2006 10:50
There is definitely something amiss with convex bodies. I had a box rigid body that did the same thing, as reported here. However, the 2 objects created before it were convex. Once I moved the convex bodies to the end of the creation process, it all worked fine again.





Redmotion
14
Years of Service
User Offline
Joined: 16th Jan 2003
Location: Mmm mmm.. Marmite
Posted: 11th Oct 2006 13:53
Did you put ALL the convex bodies to the end? (ie: more than one?)

I may try rewriting my code to do convex bodies last and see if I can use it as a workaround.

Although, last night, I had one object that just wouldn't attach to a rigid body whether I used convex OR box bodies...

BLACKMESA:SOURCE - mod for HL2 - Texture Artist
BIRTHSTAR:FRONTLINE - Texture & Environment Artist
BatVink
Moderator
14
Years of Service
User Offline
Joined: 4th Apr 2003
Location: Gods own County, UK
Posted: 12th Oct 2006 11:02
I only have 2 convex bodies, so it wasn't a major task for me. Everything else is boxes and spheres.



gwheycs62egydws
7
Years of Service
User Offline
Joined: 17th Aug 2009
Location: The World
Posted: 21st Apr 2013 01:37
I find it weird that some post get closed after a few months
and on like this are still open years latter

to move side ways - is to move forward
Since a Strait line gets thin fast
gwheycs62egydws
7
Years of Service
User Offline
Joined: 17th Aug 2009
Location: The World
Posted: 21st Apr 2013 01:37
but I guess any thing is possible

to move side ways - is to move forward
Since a Strait line gets thin fast
gwheycs62egydws
7
Years of Service
User Offline
Joined: 17th Aug 2009
Location: The World
Posted: 20th Jan 2015 19:49
and looks like this one is still open

to move side ways - is to move forward
Since a Strait line gets thin fast
MrValentine
AGK Backer
6
Years of Service
User Offline
Joined: 5th Dec 2010
Playing: Playing
Posted: 29th Jan 2015 21:14 Edited at: 29th Jan 2015 21:15
Quote: "and looks like this one is still open"


Would help if you did not keep posting and bumping it to the top then...

EDIT

If you notice ALL posts on this thread are open

Green Gandalf
12
Years of Service
User Offline
Joined: 3rd Jan 2005
Location: Cornwall UK
Posted: 4th Feb 2015 09:21
Quote: "If you notice ALL posts on this thread are open"


And indeed all threads on this board.

Quote: "Would help if you did not keep posting and bumping it to the top then..."


+1



Powered by Free Banners

Login to post a reply

Server time is: 2017-06-28 22:00:03
Your offset time is: 2017-06-28 22:00:03