Sorry your browser is not supported!

You are using an outdated browser that does not support modern web technologies, in order to use this site please update to a new browser.

Browsers supported include Chrome, FireFox, Safari, Opera, Internet Explorer 10+ or Microsoft Edge.

Dark Physics & Dark A.I. & Dark Dynamix / Emitters and textures

Author
Message
BatVink
Moderator
16
Years of Service
User Offline
Joined: 4th Apr 2003
Location: Gods own County, UK
Posted: 13th Oct 2006 17:54
I'm struggling a bit here. This is what I've found...

GHOSTing emitter objects works OK
Setting emitter objects as transparent makes them invisible (modes 1 to 6)

You can't make an emitter that gets darker with particle density, because it must be ghosted and not transparent

Anyone else have any solutions to this?



Alfred
13
Years of Service
User Offline
Joined: 22nd Jun 2006
Location: Jalisco, Mexico
Posted: 13th Oct 2006 21:26
If I recall correctly there was an old tank demo in DBC that had semitransparent smoke (dark smoke). I´ll look it up in a minute...

Hallowed are the ori.
Alfred
13
Years of Service
User Offline
Joined: 22nd Jun 2006
Location: Jalisco, Mexico
Posted: 13th Oct 2006 21:37 Edited at: 13th Oct 2006 22:04
Found it. The code says:



Texture 11 is the smoke. I would upload the texture if my connection - configuration worked properly. What I can say is that the background of the smoke is white (no alpha channel, it´s a bitmap)

Hallowed are the ori.
Alfred
13
Years of Service
User Offline
Joined: 22nd Jun 2006
Location: Jalisco, Mexico
Posted: 14th Oct 2006 00:34
Part 2 of post:


Hallowed are the ori.
BatVink
Moderator
16
Years of Service
User Offline
Joined: 4th Apr 2003
Location: Gods own County, UK
Posted: 14th Oct 2006 01:06
Thanks for the info...but it's not happening

When I use a white background, I get a light blue background in the emitter effect.



Alfred
13
Years of Service
User Offline
Joined: 22nd Jun 2006
Location: Jalisco, Mexico
Posted: 14th Oct 2006 03:28 Edited at: 14th Oct 2006 03:33
Hold on, here´s the image. Edit: Arrghh.. I can´t upload anything!

Edit2: I still can´t upload the project. I have it working on my computer fine. I can´t even post long messages!

Hallowed are the ori.
Medieval Coder
13
Years of Service
User Offline
Joined: 31st Dec 2005
Location:
Posted: 14th Oct 2006 19:08
use mode 0 for transparency.
Use a .tga, and play around with the texture.
You can make the particles grow so that may give the effect you want.

phy set emitter growth rate
then make their life longer and if that doesnt work try adding
phy set emitter gravity

BatVink
Moderator
16
Years of Service
User Offline
Joined: 4th Apr 2003
Location: Gods own County, UK
Posted: 14th Oct 2006 20:22
Mode 0 for transparency is "off". So when I use a PNG, with alpha channel, I get a white background to the texture.

I also tried using a bmp with a black background, and just using black as the alpha colour. That didn't work either, it's still invisible.

I'm now wondering if something else is interfering. It could be, for example, that the object behind is locked to the screen, or some other weird combination of functionality.



Alfred
13
Years of Service
User Offline
Joined: 22nd Jun 2006
Location: Jalisco, Mexico
Posted: 15th Oct 2006 00:31 Edited at: 15th Oct 2006 00:36
Suggestions: Edit: Ignore this post.

I tried using negative transparency. Ghost object on PARTICLE,1 - The 1 is negative tranparency. It partially works. You get black smoke but the parts that are supposed to be transparent aren´t completely transparent.

Try using ghost object off + set object PARTICLE,1,0,0,0,0,0,0 + NO TRANSPARENCY COMMANDS + NO FADING OR COLOR CHANGE IN THE PARTICLES

Hallowed are the ori.
Alfred
13
Years of Service
User Offline
Joined: 22nd Jun 2006
Location: Jalisco, Mexico
Posted: 15th Oct 2006 00:32 Edited at: 15th Oct 2006 19:14
I got it.

Do this:



Hallowed are the ori.
Alfred
13
Years of Service
User Offline
Joined: 22nd Jun 2006
Location: Jalisco, Mexico
Posted: 15th Oct 2006 00:35
In order to make it properly the background of the image that is used must be white (black smoke) and have NO alpha map. I am sure that this works. I will post a screenshot as soon as I can. (Faulty connection)

Hallowed are the ori.
Cash Curtis II
14
Years of Service
User Offline
Joined: 8th Apr 2005
Location: Corpus Christi Texas
Posted: 15th Oct 2006 14:01 Edited at: 15th Oct 2006 14:02
Alfred, we know that works. You're ghosting the emitter. The reason that the background has to be white is because you're using negative alpha blending. Regular ghosting requires a black background. Either way works properly, you just have to have the correct background on the image.

Not only are you using ghosting, in this command...
Quote: "set object 10,1,0,0,0,0,0,0"

You are specifically turning off transparency and turning on the wire frame.

Batvink is trying to use a transparency mode, not ghosting.

Batvink, there is not a single thing that is good about these particles. It's a shame, but I can't even use them. There are so many shortcomings that they're just not usable. Fortunately, I can achieve all of the results I need with the original particle pack.


Come see the WIP!
Alfred
13
Years of Service
User Offline
Joined: 22nd Jun 2006
Location: Jalisco, Mexico
Posted: 15th Oct 2006 19:21 Edited at: 15th Oct 2006 19:22
@Cash Curtis II: Yes, I haven´t found a way of using transparency without the particles disappearing . I just posted a way of making
Quote: "an emitter that gets darker with particle density"


Hallowed are the ori.
Alfred
13
Years of Service
User Offline
Joined: 22nd Jun 2006
Location: Jalisco, Mexico
Posted: 15th Oct 2006 19:22 Edited at: 15th Oct 2006 19:23
As for the command set object 10,1,0,0,0,0,0,0 i´m not turning wireframe on, I am specifically turning it off:

Quote: "When the wireframe flag is set to 0, the
object only shows its wireframe form. When the transparency flag is set to 0, all parts of the object colored black are
not drawn to the screen."
- From the help file.

Hallowed are the ori.
Alfred
13
Years of Service
User Offline
Joined: 22nd Jun 2006
Location: Jalisco, Mexico
Posted: 15th Oct 2006 19:28 Edited at: 15th Oct 2006 19:43
I hope that the image i´m posting finally uploads...
Edit: Nope, I can´t see any image. Edit2: Arghhh. This connection!!

Hallowed are the ori.
Codger
17
Years of Service
User Offline
Joined: 23rd Nov 2002
Location:
Posted: 15th Oct 2006 19:28
Alfred

No inmage

System
PIV 2.8 MZ 512 Mem
FX 5600 256 mem
BatVink
Moderator
16
Years of Service
User Offline
Joined: 4th Apr 2003
Location: Gods own County, UK
Posted: 15th Oct 2006 21:53
Thanks again for the help, but I can confirm that this hasn't worked either I've used black backgrounds, white backgrounds and transparent PNGs. When I run it in front of a white background plain, I get a "glow" effect, even with a ghost flag of -1.



Cash Curtis II
14
Years of Service
User Offline
Joined: 8th Apr 2005
Location: Corpus Christi Texas
Posted: 16th Oct 2006 03:35 Edited at: 16th Oct 2006 03:36
@Alfred -
Quote: "SET OBJECT Object Number, Wire, Transparent, Cull, Filter, Light, Fog, Ambient
set object 10,1,0,0,0,0,0,0"


The wire parameter is the second parameter, which is set to one. It probably has no effect on an emitter, and is probably set to 1 by accident. I got that from the help file


Come see the WIP!
Alfred
13
Years of Service
User Offline
Joined: 22nd Jun 2006
Location: Jalisco, Mexico
Posted: 16th Oct 2006 21:12
Quote: "When the wireframe flag is set to 0, the
object only shows its wireframe form"
- I thought that that meant that a 1 is no wireframe ¿? anyway whatever..

@BatVink: What? You still don´t have black smoke?!! Since my connection is really bad I will post the complete project here in several posts. (Please forgive my internet connection)

Hallowed are the ori.
Alfred
13
Years of Service
User Offline
Joined: 22nd Jun 2006
Location: Jalisco, Mexico
Posted: 16th Oct 2006 21:14


Hallowed are the ori.
Alfred
13
Years of Service
User Offline
Joined: 22nd Jun 2006
Location: Jalisco, Mexico
Posted: 16th Oct 2006 21:15


Hallowed are the ori.
Alfred
13
Years of Service
User Offline
Joined: 22nd Jun 2006
Location: Jalisco, Mexico
Posted: 16th Oct 2006 21:17


Hallowed are the ori.
Alfred
13
Years of Service
User Offline
Joined: 22nd Jun 2006
Location: Jalisco, Mexico
Posted: 16th Oct 2006 21:17


Hallowed are the ori.
Alfred
13
Years of Service
User Offline
Joined: 22nd Jun 2006
Location: Jalisco, Mexico
Posted: 16th Oct 2006 21:18


Hallowed are the ori.
Alfred
13
Years of Service
User Offline
Joined: 22nd Jun 2006
Location: Jalisco, Mexico
Posted: 16th Oct 2006 21:29
Put code into a new project in the "Particle Mill" demo folder.

Image: (In paint - invert colors and save as "smoke.bmp")


Hallowed are the ori.
Cash Curtis II
14
Years of Service
User Offline
Joined: 8th Apr 2005
Location: Corpus Christi Texas
Posted: 17th Oct 2006 05:44
The only problem is that ghosting is not always appropriate for a particle effect. Dark Physics currently limits alpha blending to ghosting, which is extremely limiting. I've said it time and time before, but I'll say it again that this problem might be recognized - particles are so worthless that they aren't usable.

Take the Vehicle Arena demo for example (the one with the exhaust particles). In order to stop the exhaust from being emitter, the emitter is moved to a location that is below the map. This is simply unacceptable. Particles rates should be able to be set, in this case to 0.

And with Batvink's problem, transparency cannot be used on emitters. Once again, a problem that renders particles useless.

I would just copy all of the functionality of the original particle pack, except for the collision, which of course is taken care of with the physics.


Come see the WIP!
Cash Curtis II
14
Years of Service
User Offline
Joined: 8th Apr 2005
Location: Corpus Christi Texas
Posted: 17th Oct 2006 14:53
@Alfred -
I apologize. You're right about the "set object" command, in reference to the Wireframe parameter.

My confusion is because the "set object wireframe" is opposite, a "1" sets the wireframe on, while on "set object" a "0" sets it on. I never actually use the "set object" command, but I thought they'd be the same.

Sorry about that


Come see the WIP!
Alfred
13
Years of Service
User Offline
Joined: 22nd Jun 2006
Location: Jalisco, Mexico
Posted: 17th Oct 2006 19:22 Edited at: 23rd Oct 2006 00:55
Here is what I have until now:



Hallowed are the ori.

Attachments

Login to view attachments

Login to post a reply

Server time is: 2019-12-13 16:09:12
Your offset time is: 2019-12-13 16:09:12