Sorry your browser is not supported!

You are using an outdated browser that does not support modern web technologies, in order to use this site please update to a new browser.

Browsers supported include Chrome, FireFox, Safari, Opera, Internet Explorer 10+ or Microsoft Edge.

AppGameKit Classic Chat / Compiler requires administrator level privileges

Author
Message
ABC
12
Years of Service
User Offline
Joined: 19th Sep 2011
Location:
Posted: 20th Sep 2011 02:23
Hi,

I would like to know iof you have found a solution for the problem: "Compiler requires administrator level privileges"

because actually I can not run or compile any of the AppGameKit programs.

I tried uninstalled it, also ran being administrator the called program, also allowed to the compiler all access, and checked the workspace, and in all the cases AppGameKit is unable to run any program....
always the same legend: "Compiler requires administrator level privileges"

DaveP
12
Years of Service
User Offline
Joined: 11th Sep 2011
Location:
Posted: 20th Sep 2011 07:52 Edited at: 20th Sep 2011 07:53
I was pulling my hair over this one as well - it turned out I had to load a workspace. Once I loaded the example workspace, all the files therein ran fine.

Try this:

* run the program

* go to menu: File; Open; "..\The Game Creators\AGKTrial\Projects\Basic\examples.workspace"

* double click on any item in the left pane to select it (it will go bold)

* use F4 to compile that program - the bottom log message will say 'complete' when done

* use Ctrl-F5 to run the program
Bursar
15
Years of Service
User Offline
Joined: 17th Sep 2008
Location:
Posted: 20th Sep 2011 10:23
Have you actually tried running it as Administrator? It's not the same as logging on as an administrative user.

Right click the AppGameKit icon, and choose 'Run as administrator. You'll get a little pop up box, choose Yes, and then away you go.

Login to post a reply

Server time is: 2024-02-26 12:22:01
Your offset time is: 2024-02-26 12:22:01