Sorry your browser is not supported!

You are using an outdated browser that does not support modern web technologies, in order to use this site please update to a new browser.

Browsers supported include Chrome, FireFox, Safari, Opera, Internet Explorer 10+ or Microsoft Edge.

iOS and MacOS / ld: file is universal (3 slices) but does not contain a(n) armv7s slice:

Years of Service
User Offline
Joined: 27th Jul 2004
Location: Some rainforest
Posted: 27th Sep 2012 05:14 Edited at: 27th Sep 2012 05:16
This is a solved problem which I hope help others:

After upgrading xcode to 4.5 and devices to ios6, the build on all my working projects (AGK, cordova and Shiva) failed when testing on the device (built and ran fine on simulator 6.0), I had this error:

Upon further investigation I found that the problem is solved by removing the armv7s "Architectures" on Build Settings, as well as in the "Valid Architectures" lines. This is on the project item and on the Target item (these appear on file view, clicking on project root)

Only armv7 should remain until the AppGameKit library has an armv7s slice.(I guess!)

So far all seemed to have returned to normal by changing these settings.

May the 3d force B with U
Ancient Lady
Valued Member
Years of Service
User Offline
Joined: 17th Mar 2004
Location: Anchorage, Alaska, USA
Posted: 27th Sep 2012 16:35
Thank you very much. This is very helpful information.

Happy Programming!

Ancient Lady
AGK Community Tester

Login to post a reply

Server time is: 2023-12-06 13:42:37
Your offset time is: 2023-12-06 13:42:37