Sorry your browser is not supported!

You are using an outdated browser that does not support modern web technologies, in order to use this site please update to a new browser.

Browsers supported include Chrome, FireFox, Safari, Opera, Internet Explorer 10+ or Microsoft Edge.

DarkBASIC Professional Discussion / Dark Dinamix error: Limb 0 and 1 has no mesh data?

Years of Service
User Offline
Joined: 17th Feb 2015
Posted: 13th Jan 2017 14:28
Hello everybody.
I've tried to load a 3D model into Dark Dinamix ragdoll example project, but I get an error:
Quote: "Limb:1 in object:1 has no mesh data"

And that results in the ragdoll not working.

I understood that some of the bones in the model has no associated mesh attached to them.
I modified the model in Milkshape 3D.
But, even after deleting all bones that didn't have mesh data, I still get the same error.
I inspected the exported .x model in 3D Object Viewer, and there are still bone number 0 and 1 existing, which looks like 'root' bone. I think they were created automatically during export, as I can't find those bones in Milkshape editor.

Anybody knows how to get rid of the problematic bones?
Thanks in advance.
Here's the milkshape model


Login to view attachments

Login to post a reply

Server time is: 2023-09-29 00:47:46
Your offset time is: 2023-09-29 00:47:46