Sorry your browser is not supported!

You are using an outdated browser that does not support modern web technologies, in order to use this site please update to a new browser.

Browsers supported include Chrome, FireFox, Safari, Opera, Internet Explorer 10+ or Microsoft Edge.

DarkBASIC Professional Discussion / Can I Play Animation (Video) in DBPro Open Source?

Author
Message
Dispenser Ting
7
Years of Service
User Offline
Joined: 18th May 2016
Location:
Posted: 14th Jul 2017 09:38
I try several simple codes it does not run well.
When I use AVI format, the video play in active window.
When I use MPG/MP4 format, the did't appear at all, but the audio is playing.

Very wired...HELP PLS
zero32
7
Years of Service
User Offline
Joined: 28th Jul 2016
Location:
Posted: 15th Jul 2017 00:30
i think it is a video codec issue. either you are missing a video codec or your video codec is not compatible with dark basic pro.
you can try to open the video files in windows media player. if they do play without problems then it is NOT a codec issue, else try the K-lite codec pack: https://www.codecguide.com/download_kl.htm
but keep in mind if you cannot run the code, others may also have the same issues if you share your programm later. they may also need the codec pack.
Dispenser Ting
7
Years of Service
User Offline
Joined: 18th May 2016
Location:
Posted: 17th Jul 2017 10:03
@zero32

Then is more weird. I can play by using window media player nor K-lite codec externally. Which I play the video using any player in my laptop had no problem with that, but not in the dark basic pro. I will try to uninstall K-lite codec see what happen next. Just try everything...

Mage
17
Years of Service
User Offline
Joined: 3rd Feb 2007
Location: Canada
Posted: 18th Jul 2017 00:39
Dispenser Ting wrote: "When I use AVI format, the video play in active window."

There is a programming work around for this but it is very complicated.

Login to post a reply

Server time is: 2024-03-01 01:14:43
Your offset time is: 2024-03-01 01:14:43