Sorry your browser is not supported!

You are using an outdated browser that does not support modern web technologies, in order to use this site please update to a new browser.

Browsers supported include Chrome, FireFox, Safari, Opera, Internet Explorer 10+ or Microsoft Edge.

Raspberry Pi / AGK wont open?

Years of Service
User Offline
Joined: 13th May 2018
Posted: 13th May 2018 07:05
When I click on the AppGameKit executable inside the AGKPi folder the cursor says its loading something but nothing appears. This is on the latest version of jessie and the latest version of AppGameKit (2018.05.02).
Tone Dialer
Valued Member
Years of Service
User Offline
Joined: 17th Oct 2005
Location: England, well a town in it !
Posted: 15th May 2018 10:22

I would recommend using the latest Raspbian Stretch, I have had no problems using AppGameKit (2018.05.02) with it.
It loads, compiles and broadcasts OK.
Perhaps you could install Stretch and AGKpi on a new SD card.
Valued Member
Years of Service
User Offline
Joined: 28th Nov 2002
Location: Denmark
Posted: 30th May 2018 21:23 Edited at: 30th May 2018 21:24
@num, try the steps mentioned in this thread:

Summed up, it is this:

1. Installed fresh Raspbian Stretch 2018-03-13
2. Downloaded and unpacked AGKPi 2017-09-25
3. (Terminal) sudo apt-get update
4. (Terminal) sudo apt-get dist-upgrade
5. (From start menu) reboot
6. (Terminal) sudo apt-get install libsdl2-dev
7. (From start menu) reboot
8. (Terminal) sudo rpi-update (This seems to be the essential part as it also updates "Video something". First time I did this with the fresh install, it would not boot afterward, but it seems like the firmware lives on the SD card, so a new install made it work again)
9. (From start menu) Shutdown, wait until disk LED stops blinking, unplugged power, waited 10 sec, plugged power back in.
10. Compiled a simple AppGameKit Tier 1 app and ran it from terminal like this ./Core (Core being the app I ran). (I use ./ to get output to get an idea of what goes wrong)

If it still doesn't work, try this as suggested by rTomas:
11. sudo raspi-config > 7 Advanced Options > A7 GL Driver > G3 Legacy > reboot

Let us know if this works for you. I used Stretch by the way.
FPSC Reloaded TGC Backer
Years of Service
User Offline
Joined: 17th Apr 2007
Location: Berlin
Posted: 11th Jul 2018 06:29
error while lading shared libraries:
can't open shared object files: No such file or directory

So I think, I still have to rename something :-(

Login to post a reply

Server time is: 2024-02-26 13:35:20
Your offset time is: 2024-02-26 13:35:20