Sorry your browser is not supported!

You are using an outdated browser that does not support modern web technologies, in order to use this site please update to a new browser.

Browsers supported include Chrome, FireFox, Safari, Opera, Internet Explorer 10+ or Microsoft Edge.

Raspberry Pi / Fresh Raspian Buster September 2019 and AGK from 2019.09.027 are working together on a Pi 3B+, How to

Years of Service
User Offline
Joined: 15th Sep 2009
Posted: 8th Oct 2019 14:01
yes, and here is how i solved that:

copy the AppGameKit-V2019.09.27-RaspPi.tar.gz to the raspberry desktop and expand it.
you can start the IDE, load a example.
No Error during compile, but
If you execute the file via RUN, nothing happens.

close IDE, open a Shell(Terminal) .
change directory to the AGKPi one.
here i do that with:

cd Desktop
cd AGKPi

then i run the ide from this shell via:


i noticed a GTK_Tree_view error, but that is not important.

The example is also loaded, so i press the RUN Button in the IDE again.

In the shell you see a error with libglesv2 , a missing one

you have 2 options to install the missing library,

1. use the ADD/Remove Software and search for LibGLES2.
install the libgles2-mesa-dev-xxxxxx


2. via shell
sudo apt-get install libgles2-mesa-dev

Next, everthing went ok or you got a complete other
error while try to run the example.
A block window is shown , shortly.
This error can be solved by update you raspberry pi firmware with:

sudo rpi-update
(follow the instructions )

After a reboot all went well here .

Tone Dialer
Valued Member
Years of Service
User Offline
Joined: 17th Oct 2005
Location: England, well a town in it !
Posted: 19th Oct 2019 12:26

Thank you for posting the above method it was very useful.

I used a clean install of Raspbian Buster with desktop & recommended software [Release date 2019-09-26, Kernel 4.19]

First I manually set the Raspberry Pi system Time and Date and then enabled NTP time sync, using:

Open a Shell window

sudo date -S"Oct 19 2019 10:00" {adjust for todays date and time}

sudo timedatectl set-ntp True

Shutdown, Power off, Reboot.

Open a Shell window

sudo apt-get update

sudo apt-get install libgles2-mesa-dev

sudo rpi-update


Login to post a reply

Server time is: 2023-12-08 13:20:05
Your offset time is: 2023-12-08 13:20:05