Sorry your browser is not supported!

You are using an outdated browser that does not support modern web technologies, in order to use this site please update to a new browser.

Browsers supported include Chrome, FireFox, Safari, Opera, Internet Explorer 10+ or Microsoft Edge.

AppGameKit Studio Chat / [SOLVED] New scenes not appearing in Studio IDE

Years of Service
User Offline
Joined: 15th Jul 2011
Posted: 10th Oct 2021 14:40

AppGameKit Studio V2021.09.30 on Steam.

When I right-click a project in the Studio IDE, and select "Add new scene to project", the scene file is created in the project folder, but the scene is not listed as a file in the IDE.

The first time this happened, I did "Add file to Project", selected the scene file in the browser, and it appeared in the IDE. Now that doesn't work either.

I have been using AppGameKit Studio for a week, and I have been able to created scenes up until now.

The Scene Manager window is not hidden in the View menu; I can see a scene that I previously created, but new scenes are not added to the IDE.

I have tested this in existing and new projects, with the same results.

Can anyone advise what I'm doing wrong?


Login to view attachments

The author of this post has marked a post as an answer.

Go to answer

Virtual Nomad
Years of Service
User Offline
Joined: 14th Dec 2005
Location: SF Bay Area, USA
Posted: 10th Oct 2021 19:36 Edited at: 11th Oct 2021 00:54
This post has been marked by the post author as the answer.
i just tested this by adding a scene ("0010") to a project called Hover* and experienced the same (WIN10).

i followed this advice for similar IDE issue and the new scene stayed visible on re-launch.

it's not the most eloquent solution where it will reset everything but it worked.

*since the reset, i went into agkide.layout and found these 2 entries for Hover:

note the Dockids (0,1).

i added another scene "0020" and checked the .layout file and found:

ie, id = xxxx,2

so, i wonder if you can get yours to show (without the "hard" reset above) by building a similar entry in the .layout file (keeping everything the same as the ##ProjectName.agk but making it XXX.scene##ProjectName.agk) instead and increasing the dockid by 1 (may not even be necessary. i wonder what the IDE would do if it was the same)? reset itself?)?

otherwise, deleting the .layout file alone (vs the whole folder) might do the trick where we could probably save the other stuff (agkide.ini, layout preferences, etc,) while fixing this/similar?


add: i re-read your post and realized that i didn't answer your question, "Can anyone advise what I'm doing wrong?"; i don't know that you did do anything wrong. sorry about that.

meanwhile, from the user guide @ Preferences/IDE:

Only Display Active Project Files
This is on by default. If you tick it off then all the files from the projects list will be displayed at the top of the IDE in tabs.

i'm not sure what "active" means. only the one that's currently being worked with? regardless, ALL scenes that are added to a project, whether created anew or brought in via Add File should show in the project window.
[My Home] [AGK on]
[AGK Resource Directory] [TGC @ GitHub]
[AGK Showcase][Google Forum Search]
Years of Service
User Offline
Joined: 15th Jul 2011
Posted: 11th Oct 2021 07:34
Thank you very much for taking the time to reply.

I went for the 'hard reset' option, and deleted the 'Ide' file, and that appears to have resolved the problem.

Fortunately, I had not customised the IDE, so it didn't cause me any extra work.

I did have to change the toolbar icons and font sizes (to the smaller, default size that I had upon original installation), which surprised me, because I hadn't made any changes to those, but that was easy enough.

Thanks again.
AGK Tool Maker
Years of Service
User Offline
Joined: 9th Mar 2015
Location: London UK
Posted: 26th Oct 2021 16:34
I just had the same issue, applied same fix

Quote: "the fix was to delete the folder 'Ide' in 'C:\Users\[username]\AppData\Local\AGKApps\TheGameCreators' that should reset everything"

Very odd, it creates the file but fails to add it to the project, I open it in the IDE and its blank bar a single comment at the head.
Open Source plugins
Cl - DnD Plugin
Buy Me A Coffee

Login to post a reply

Server time is: 2023-06-08 13:00:33
Your offset time is: 2023-06-08 13:00:33