Sorry your browser is not supported!

You are using an outdated browser that does not support modern web technologies, in order to use this site please update to a new browser.

Browsers supported include Chrome, FireFox, Safari, Opera, Internet Explorer 10+ or Microsoft Edge.

Raspberry Pi / Appgamekit 2021_06_14 did not work under Raspbian GNU/Linux 11 (bullseye)

Author
Message
Rings
12
Years of Service
User Offline
Joined: 15th Sep 2009
Location:
Posted: 28th Dec 2021 18:30

tboy
9
Years of Service
User Offline
Joined: 1st Jan 2013
Location: UK
Posted: 5th Jan 2022 22:44 Edited at: 5th Jan 2022 22:57
Hi Rings,

I'm assuming you're using a PI 4?

OpenMAX is deprecated on Bullseye, you will need to build the PiPlayer using AppGameKit Tier2 because the AppGameKit Player on the Pi builds against libopenmaxil.so

If you try the Linux command ldd on the PiPlayer:

linux-vdso.so.1 (0xbef91000)
/usr/lib/arm-linux-gnueabihf/libarmmem-${PLATFORM}.so => /usr/lib/arm-linux-gnueabihf/libarmmem-v7l.so (0xb6fa0000)
libGLESv2.so => /usr/lib/arm-linux-gnueabihf/libGLESv2.so (0xb6f5c000)
libEGL.so => /usr/lib/arm-linux-gnueabihf/libEGL.so (0xb6f3d000)
libopenmaxil.so => /opt/vc/lib/libopenmaxil.so (0xb6f27000)
libbcm_host.so => /opt/vc/lib/libbcm_host.so (0xb6f00000)
libXrandr.so.2 => /usr/lib/arm-linux-gnueabihf/libXrandr.so.2 (0xb6ee7000)
libpthread.so.0 => /lib/arm-linux-gnueabihf/libpthread.so.0 (0xb6ebd000)
libopenal.so.1 => /usr/lib/arm-linux-gnueabihf/libopenal.so.1 (0xb6dd6000)
libudev.so.1 => /lib/arm-linux-gnueabihf/libudev.so.1 (0xb6da6000)
librt.so.1 => /lib/arm-linux-gnueabihf/librt.so.1 (0xb6d8f000)
libXxf86vm.so.1 => /usr/lib/arm-linux-gnueabihf/libXxf86vm.so.1 (0xb6d7a000)
libXext.so.6 => /usr/lib/arm-linux-gnueabihf/libXext.so.6 (0xb6d5b000)
libX11.so.6 => /usr/lib/arm-linux-gnueabihf/libX11.so.6 (0xb6c39000)
libstdc++.so.6 => /usr/lib/arm-linux-gnueabihf/libstdc++.so.6 (0xb6af2000)
libm.so.6 => /lib/arm-linux-gnueabihf/libm.so.6 (0xb6a70000)
libgcc_s.so.1 => /lib/arm-linux-gnueabihf/libgcc_s.so.1 (0xb6a43000)
libc.so.6 => /lib/arm-linux-gnueabihf/libc.so.6 (0xb68f5000)
libGLdispatch.so.0 => /usr/lib/arm-linux-gnueabihf/libGLdispatch.so.0 (0xb6876000)
libdl.so.2 => /lib/arm-linux-gnueabihf/libdl.so.2 (0xb6863000)
/lib/ld-linux-armhf.so.3 (0xb6fb5000)
libbrcmGLESv2.so => /opt/vc/lib/libbrcmGLESv2.so (0xb683e000)
libbrcmEGL.so => /opt/vc/lib/libbrcmEGL.so (0xb6805000)
libvchiq_arm.so => /opt/vc/lib/libvchiq_arm.so (0xb67ef000)
libvcos.so => /opt/vc/lib/libvcos.so (0xb67d6000)
libXrender.so.1 => /usr/lib/arm-linux-gnueabihf/libXrender.so.1 (0xb67bd000)
libsndio.so.7.0 => /usr/lib/arm-linux-gnueabihf/libsndio.so.7.0 (0xb679e000)
libatomic.so.1 => /usr/lib/arm-linux-gnueabihf/libatomic.so.1 (0xb6785000)
libxcb.so.1 => /usr/lib/arm-linux-gnueabihf/libxcb.so.1 (0xb6756000)
libasound.so.2 => /usr/lib/arm-linux-gnueabihf/libasound.so.2 (0xb6675000)
libbsd.so.0 => /usr/lib/arm-linux-gnueabihf/libbsd.so.0 (0xb664d000)
libXau.so.6 => /usr/lib/arm-linux-gnueabihf/libXau.so.6 (0xb663a000)
libXdmcp.so.6 => /usr/lib/arm-linux-gnueabihf/libXdmcp.so.6 (0xb6625000)

If it's any help, I've attached a PiPlayer that I built using Tier2 to get it working on Buster.

Hopefully it works for you.

Attachments

Login to view attachments
Fud
17
Years of Service
User Offline
Joined: 16th Nov 2004
Location:
Posted: 7th Jan 2022 12:50
Thank you tboy!
The PiPlayer that you've attached works on my RPI 3 with buster.
I've spent way too long trying to get it to work, you've made my day!

tboy
9
Years of Service
User Offline
Joined: 1st Jan 2013
Location: UK
Posted: 7th Jan 2022 13:53
@Fud,

That's good news! I wonder if you'll be able to use the 3D examples ok, as I changed a small part of the shader code to
get it displaying 3D scenes correctly on RPi4.

Reply back here if it doesn't work, if not I'll change the code to the original code (works on RPI3) and upload
the changes here.

I can also confirm it works on Bullseye as I'm using it now (RPi4).
tboy
9
Years of Service
User Offline
Joined: 1st Jan 2013
Location: UK
Posted: 7th Jan 2022 19:54
I had a problem getting AGKBroadcaster working with Raspberry Pi OS - Bullseye.

There were a few dependencies missing:

libopenmaxil.so
libbrcmGLESv2.so
libbrcmEGL.so


if you use ldd AGKBroadcaster and see the output for the required missing files, you can copy them
from your 'Buster' version of Raspbian from opt/vc/lib or download them from the raspberry pi repository.

https://github.com/raspberrypi/firmware/tree/master/opt/vc/lib

I copied the files to /usr/lib/arm-linux-gnueabihf

Hope it helps!

Login to post a reply

Server time is: 2022-05-26 08:06:34
Your offset time is: 2022-05-26 08:06:34