Sorry your browser is not supported!

You are using an outdated browser that does not support modern web technologies, in order to use this site please update to a new browser.

Browsers supported include Chrome, FireFox, Safari, Opera, Internet Explorer 10+ or Microsoft Edge.

AppGameKit Studio Chat / Weird (new) errors when compiling on MAC for IOS

Author
Message
Abiz
11
Years of Service
User Offline
Joined: 14th Nov 2012
Location: Amsterdam
Posted: 19th Oct 2023 22:57
I have compile my app every day now, but today I go a new (never seen) error.
My MAC is up to date, XCode has been upgraded and is up to date.

See the attached screenshots (since AppGameKit won't let me copy the text).
Help is needed.

Thanks

Attachments

Login to view attachments
Abiz
11
Years of Service
User Offline
Joined: 14th Nov 2012
Location: Amsterdam
Posted: 20th Oct 2023 16:23
I found the solution and compilation is working again.

- October 18, Apple released X-Code 15.0.1, which will compile for IOS 17
- However, the IOS 17 runtime simulator is not automatically installed
- After I upgraded to SONOMA and restarted X-Code 15.0.1 it asked to install additional modules
- It then installed IOS 17 runtime simulator, after which compilation was successful again.
Aidan
User Banned
Posted: 20th Oct 2023 16:24 Edited at: 20th Oct 2023 16:25
Well done

And most importantly thanks for sharing your fix

Login to post a reply

Server time is: 2024-03-02 19:18:02
Your offset time is: 2024-03-02 19:18:02