Sorry your browser is not supported!

You are using an outdated browser that does not support modern web technologies, in order to use this site please update to a new browser.

Browsers supported include Chrome, FireFox, Safari, Opera, Internet Explorer 10+ or Microsoft Edge.

2D All the way! / Image Loading Error

Author
Message
Vid
20
Years of Service
User Offline
Joined: 3rd Mar 2003
Location: United States
Posted: 4th Mar 2003 03:17
In my code i will use a typical Load image snippet but it says it cannot find the image such as:
Load image "imagename", 1

but it doesnt work(and yes the image is in the same directory as project
when i put the full directory name it works such as:
Load image "C:\DarkBasic\projects\imagename", 1

Please Help
ChopChop
20
Years of Service
User Offline
Joined: 2nd Mar 2003
Location:
Posted: 4th Mar 2003 08:04
Hi Vid,
Have you tried to a relative path i.e
Load image "\imagename", 1

NETMAN007
20
Years of Service
User Offline
Joined: 16th Jan 2003
Location: Malta
Posted: 4th Mar 2003 12:25
Do you write the file extenstion after the imagename
i.e. Load Image "C:\Dark Basic\projects\imagename.jpg"
or .bmp etc.
If you do not write the extension after the name the command will not work.

Richard Davey
Retired Moderator
21
Years of Service
User Offline
Joined: 30th Apr 2002
Location: On the Jupiter Probe
Posted: 4th Mar 2003 16:05
Another problem might be that you have not created a Project properly. If you just start DBPro and start writing code without making a Project, you're working in the Temp directory - so obviously the command will fail because I bet your image isn't in there Make a proper Project, copy the image into it and use "load whatever.xxx" and there is no reason why it won't work.

Cheers,

Rich

"Gentlemen, we are about to short-circuit the Universe!"
DB Team / Atari ST / DarkForge / Retro Gaming
Vid
20
Years of Service
User Offline
Joined: 3rd Mar 2003
Location: United States
Posted: 5th Mar 2003 01:02
thanks rich you nailed tha problem.

Vid
20
Years of Service
User Offline
Joined: 3rd Mar 2003
Location: United States
Posted: 5th Mar 2003 01:02
tha should be the but im an idiot

Login to post a reply

Server time is: 2023-09-29 10:39:26
Your offset time is: 2023-09-29 10:39:26