Quote: "So if the only reasoning is that it might save some users a few trips to the help files ? - Then that doesn't seem like a strong argument for change to me."
I don't think that was even the main reasoning to begin with, calling functions and accessing arrays are completely different concepts so they should be separated in terms of syntax is the main reason.
To put it another way, gosub and goto in DBPro are completely different concepts, but they both use the same syntax, except gosub's target label requires a return statement somewhere after the label. Yes, the user has written the gosub label with the paired return statement, but it's not immediately clear what's going on if you just see the label. This syntax change is the equivalent of proposing the gosub label/return construct be altered to be easily distinguishable from the goto label, because their usage is very different. (and yes, I think the gosub/goto should be changed so that goto uses the current label system and gosub no longer exists)
Quote: "Just to play devils advocate for a second, why not use  for function calls and () for arrays ? - The reasoning is just as sound what's being proposed."
Why not replace the '=' assignment operator with 'pony'? Because no one else does.